Markizka22
25.01.2021 13:38

Написать программу с++ Получить информацию о центральном процессоре, о bios.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vitalik200220
15.10.2020 23:37
по информатике, Реализовать программу следующего задания не менее чем двумя

вариантами разных циклов (например, с заранее заданным

количеством повторений, с предусловиями, с постусловиями, с

меткой и разветвлением).

В массиве из 15 элементов (ввод переменных – на ваше усмотрение)

подсчитать количество положительных (четных) и сумму

отрицательных элементов по информатике, Реализовать программу следующего задания не менее чем двумя

вариантами разных циклов (например, с заранее заданным

количеством повторений, с предусловиями, с постусловиями, с

меткой и разветвлением).

В массиве из 15 элементов (ввод переменных – на ваше усмотрение)

подсчитать количество положительных (четных) и сумму

отрицательных элементов.

Объяснение:

0,0(0 оценок)
Ответ:
makssabarov
18.10.2021 19:06

1)

var i,n:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[i]); readln;

for i:=1 to n do write(a[ i]:8); writeln;

for i:=n downto 1 do write(a[i]:8); writeln;

writeln('Для выхода нажмите Enter'); readln

end.

2)

var i,n:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[ i]); readln;

for i:=1 to n do if a[i]<0 then write(i:2,a[i]:8); writeln;

writeln('Для выхода нажмите Enter'); readln

end.

3)

var i,n:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[i]); readln;

for i:=1 to n do if not odd(i) then write(a[i]:8); writeln;

writeln('Для выхода нажмите Enter'); readln

end.

4)

var i,n,s:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[i]); readln;

for i:=1 to n do write(a[i]:8); writeln;

s:=0; for i:=1 to n do s:=s+a[i]; writeln('Sum=',s); ;

writeln('Для выхода нажмите Enter'); readln

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота