Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (паскаль)
Var mas30: array [1..30] of integer; var i, proz: integer; begin proz:=1; for i:=1 to 30 do begin mas30[i]:=-5+random (11); //Заполнение массива write (mas30[i], ' '); //вывод значений массива end; writeln; for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; //Подсчет произведения отриц элементов writeln (proz); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку