праллель
15.04.2021 00:19

Напишите программу , которая вводит число n и определяет является ли число n совершенным. совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Recor23
17.07.2020 17:36
Var n, i, s:integer;
begin
read(n);
s:=0;
for i:=1 to n-1 do begin
   if n mod i = 0 then s:=s+i;
end;
if s = n then writeln('sovershennoye') else writeln('ne sovershennoye');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота