ArtyomKashin
18.08.2022 20:15

№1 составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными значениями. №2 составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 такое же как и №2, только массива с четными значениями.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
fietisov
25.05.2020 21:51

var a:array[1..10]of integer;
n1,n2,s,i:integer;
begin
n1:=1;
n2:=1;
for i:=1 to 10 do a[i]:=random(10)+1;
for i:=1 to 10 do begin
if a[i] mod 2=0 then n1:=n1*a[i] else n2:=n2*a[i];
s:=s+a[i];
end;
writeln(n1,' ',n2,' ',s/10);
end.

 

 

Объеденил все 3 программы: вначале выводит произведение четных, потом нечетных, потом среднее арифм.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота