Христя2017
04.04.2020 17:24

Составить программу, которая находит и выводит сумму всех натуральных чисел из отрезка от А до В, кратных 5 и 13 (А и В водятся с клавиатуры)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zhabinalena1
16.01.2022 07:46
Более изящное решение :)

Проблема в строке c:= (b*b*b);
Ты ищешь сумму кубов, а для 4-значных чисел нужно искать сумму 4-х степеней. Нужно проверять число а: если от 100 до 999, то выполняем c:= (b*b*b); а если от 1000 до 9999, то выполняем c:= (b*b*b*b); 

Код ниже работает и выдаёт результат:
число Армстронга ==> 153
число Армстронга ==> 370
число Армстронга ==> 371
число Армстронга ==> 407
число Армстронга ==> 1634
число Армстронга ==> 8208
число Армстронга ==> 9474


var a,b,c,d,a2:integer;
begin
for a:=100 to 9999 do begin
d:=0;
a2:=a;
while (a2 <> 0) do begin
b:= a2 mod 10;
a2:= a2 div 10;
if a<1000 then c:= (b*b*b)
      else c:= (b*b*b*b);
d:= d+c;
end;
if (a = d) then writeln('число Армстронга ==> ', a);
end;
end.
0,0(0 оценок)
Ответ:
отличница54575
22.06.2021 04:08
Const n=10;
var a,g: array [1..100] of integer;
var b : array [1..100] of string;
var k: integer;

begin

writeln ('ответы вводятся строкой без пробелов. Пример: 12345');
b[1]:='1. Общество в широком смысле слова – это '+NewLine+
' 1) территория обитания людей'+NewLine+
' 2) история человечества'+NewLine+
' 3) совокупность форм объединения людей'+NewLine+
' 4) производительные силы';

b[2]:= '2. Обществознание – это '+NewLine+
' 1) наука'+NewLine+
' 2) учебная дисциплина'+NewLine+
' 3) комплекс наук об обществе и человеке'+NewLine+
' 4) сфера естественнонаучного знания'+NewLine+
' 5) сфера гуманитарного знания';

b[3]:= '3. Человек отличается от животного наличием'+NewLine+
' 1) языка'+NewLine+
' 2) разума'+NewLine+
' 3) сознанием'+NewLine+
' 4) трудовой деятельности'+NewLine+
' 5) мышления';

b[4]:= '4. Личность возможна (Определить неверный ответ)'+NewLine+
' 1) без морали'+NewLine+
' 2) без гражданственности'+NewLine+
' 3) без ответственности'+NewLine+
' 4) без диплома о высшем образовании';

b[5]:= '5. Человек и общество'+NewLine+
' 1) человек первичен по отношению к обществу'+NewLine+
' 2) общество первично по отношению к человеку'+NewLine+
' 3) человек и общество взаимно обусловлены'+NewLine+
' 4) общество и человек развиваются независимо друг от друга';

b[6]:= '6. Мораль в религии основывается'+NewLine+
' 1) на разуме'+NewLine+
' 2) на вере'+NewLine+
' 3) на долге'+NewLine+
' 4) на свободе';

b[7]:= '7. Целью развитой религии является достижение'+NewLine+
' 1) материального благополучия'+NewLine+
' 2) социального положения и значимости'+NewLine+
души'+NewLine+
' 4) познание мира'+NewLine+
' 5) управление силами природы';

b[8]:= '8. К монотеистическим религиям относятся'+NewLine+
' 1) индуизм'+NewLine+
' 2) ислам'+NewLine+
' 3) буддизм'+NewLine+
' 4) язычество';

b[9]:= '9. К основным моральным категориям относятся (определить неверный ответ)'+NewLine+
' 1) добро'+NewLine+
' 2) справедливость'+NewLine+
' 3) совесть'+NewLine+
' 4) выгода'+NewLine+
' 5) любовь';

b[10]:= '10. Мораль проявляется в следовании'+NewLine+
' 1) интересам власти'+NewLine+
' 2) общественному мнению'+NewLine+
' 3) анимизму'+NewLine+
' 4) гороскопу'+NewLine+
' 5) внутреннему «Я» человека';

a[1]:=3;
a[2]:=23;
a[3]:=12345;
a[4]:=4;
a[5]:=3;
a[6]:=2;
a[7]:=3;
a[8]:=23;
a[9]:=4;
a[10]:=5;

k:=0;
for var i:=1 to n do begin
 writeln(b[i]); 
 readln(g[i]);
 if g[i]=a[i] then k:=k+1;
end;
writeln ('Ваша оценка: ',k/2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота