TreYsYer
09.05.2023 05:58

Вычислить: номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.написать программу в

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Keranius
16.07.2020 20:53
const  n = 5;   var   a: array[1..n] of integer;   i, k: integer;   s: real;   begin   s := 0;   for i := 1 to n do   begin     readln(a[i]);     s := s + a[i];   end;   s := s / n;   writeln('Среднее значение = ', s:0:3);   k := 1;   for i := 2 to n do     if abs(a[k] - s) > abs(a[i] - s) then k := i;     writeln('Индекс элемента: ', k, ' Значение = ', a[k]); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота