SuperMax2003rus
05.04.2022 01:35

Составьте программу определяющую, является ли число x простым

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Maciel
25.05.2020 20:42
Uses crt; var a : real; p : boolean; i : integer; procedure haltproc; begin writeln('неверные данные'); writeln('a>=2');readln; halt; end; begin clrscr; write('a=');readln(a); if a<2 then haltproc; if a=2 then begin writeln2('простое'); readln;halt; end; p:=true; for i:=2 to trunc(a-1) do if a/i=trunc(a/i) then p:=false; if p=true then write('простое') else write('не простое'); readln; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота