помоги1361
24.12.2022 11:47

Напишите программу на паскале -точка (x, y) находится в области a; – точка (x, y) находится в области b; – точка (x, y) находится в области c; – точка (x, y) находится вне всех областей. примечание: точки, лежащие на разделительных линиях, принад-лежат области b.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
НЕЗНАЙКА2283371
16.11.2021 17:31
//Pascal ABC.NET v3.1 сборка 1172

Var
 ma:array of array of integer;
 i,j,n,r:integer;
begin
 readln(n);
 setlength(ma,n+1);
 for i:=1 to n do
 setlength(ma[i],n+1);
 writeln('Matrix:');
 for i:=1 to n do
 begin
  writeln;
  for j:=1 to n do
   begin
    ma[i,j]:=random(n);
    write(ma[i,j]:4);
   end;
 end;
 for i:=1 to n do
  for j:=i+1 to n do
  r:=r+ma[i,j];
 r:=r div 3;
 writeln;
 if odd(r) then writeln('Да') else writeln('Нет');
end.

Пример ввода:
4
Пример вывода:
Matrix:

   0   1   3   3
   3   0   0   3
   2   3   0   2
   3   0   2   3
Нет
0,0(0 оценок)
Ответ:
Maestror
16.11.2021 17:31
//Pascal ABC.NET v3.1 сборка 1172

Var
 ma:array of array of integer;
 i,j,n,r:integer;
begin
 readln(n);
 setlength(ma,n+1);
 for i:=1 to n do
 setlength(ma[i],n+1);
 writeln('Matrix:');
 for i:=1 to n do
 begin
  writeln;
  for j:=1 to n do
   begin
    ma[i,j]:=random(n);
    write(ma[i,j]:4);
   end;
 end;
 for i:=1 to n do
  for j:=i+1 to n do
  r:=r+ma[i,j];
 r:=r div 3;
 writeln;
 if odd(r) then writeln('Да') else writeln('Нет');
end.

Пример ввода:
4
Пример вывода:
Matrix:

   0   1   3   3
   3   0   0   3
   2   3   0   2
   3   0   2   3
Нет
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота