kokorev861oxc4k3
15.03.2021 03:26

Язык - pascal. даны натуральное число n и последовательностьa1, an. составьте программу,которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Александр756
15.07.2020 20:45
Var
 n, i, s, a, k: integer;
begin
readln(n);
s := 0;
k := 0;
for i := 1 to n do
begin
read(a);
if (a mod 3 = 0) and (a mod 9 <> 0) then
begin
inc(k);
inc(s, a);
end;
end;
write(s div k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота