Kr3sher
13.02.2021 05:40

По программированию. можно на любом языке.строка называется палиндромом, если читается одинаково слева-направо и справа-налево. например, строка 4554 является палиндромом. будем рассматривать строки, состоящие из цифр и знаков вопроса, при этом знак вопроса можно заменить на любую цифры. например, строка 4? 5? также является палиндромом, так как первый вопросительный знак можно заменить на 5, а второй — на 4, после чего строка станет палиндромом.рассмотрим последовательность из n строк, каждая из которых состоит из n символов. их можно рассматривать как таблицу размером n на n. если в такой таблице каждый столбец является палиндромом, то назовем такую таблицу квадропалиндромом.по заданному множеству из n n-символьных строк вам требуется составить квадропалиндром, переставив строки в нужном порядке или определить, что это невозможно.формат вводав первой строке входных данных задаётся число n (1 ≤ n ≤ 8).в следующих n строках заданы строки, состоящие из цифр и вопросительных знаков, по n символов в каждой.формат выводавыведите строки в нужном порядке. если решений несколько — выведите любое из них. если решения не существует — выведите ”no solution” (без кавычек).примерввод вывод3 126? 46 ? 4612? 12? 126

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Noooo123456
27.09.2022 21:02

program raf105;

var

 s,s1,s2: string;

 slov,numb,i,j,l: integer;

begin

writeln('Введите строку:');

readln(s);

s:= lowercase(s);

s1:= '';

s2:= '1234567890';

while j<>-1 do

begin

 j+= 1;

 l+= 1;

 for i:=1 to length(s1) do

   if (s[j] = s1[i]) and (slov = 0)

     then slov+= 1

     else if (i<=length(s2)) and (s[j] = s2[i])

     then numb+=1;

 if s[j+1] = ' '

   then j:= -1;

end;

for i:=l+1 to length(s) do

begin

 if s[i] = ' '

   then

   begin

     for j:=1 to length(s1) do

       if s[i+1] = s1[j]

         then slov+= 1;

   end

   else

   begin

     for j:=1 to length(s2) do

       if s[i] = s2[j]

         then numb+=1;

   end;;

end;

writeln;

writeln('В строке:');

writeln(slov,' сл.');

writeln(numb,' циф.');

end.

Язык PascalABC
0,0(0 оценок)
Ответ:

ответ:Дерево игры - в прилагаемом файле. У игрока, делающего ход первым (Пети) есть выигрышная стратегия: первый ход должен быть +3 (в куче получится 13 камней). В этом случае при ходе второго игрока (Вани) +3 (в куче 16 камней) первый (Петя) выигрывает ходом *2 (в куче 32 камня); при ходе второго игрока (Вани) *2 (в куче 26 камней) первый (Петя) также выигрывает ходом *2 (в куче 52 камня). Второй игрок (Ваня) может выиграть только в случае, если первый (Петя) сделает начальный ход *2 (в куче 20 камней), следующий ход (Вани) *2 (в куче 40 камней) приводит к выигрышу.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота