Яркf
10.03.2022 10:32

3. написать программу, которая вводит массив из n вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число z, этим числом. вывести на экран полученный массив и количе-ство замен. протестировать программу на следующих исходных данных: а) z=10 массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15 б) z=-2 массив: 0 -3,1 11 -7,9 -2,1 -1,9 4 на паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
568500
15.07.2020 15:29
Var i,j,z,n,count:integer;
var a:array[1..1000] of integer;
begin
writeln('Введите Z: ');
readln(z);
writeln('Введите N: ');
readln(n);
writeln('Введите N чисел через пробел: ');
count:=0;
for i:=1 to n do begin
read(j);
if j<=z then a[i]:=j 
else begin a[i]:=z; count:=count+1; end;
end;
writeln('Количество замен: ',count);
write('Полученный массив: ');
for i:=1 to n do write(a[i], ' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота