RGROP17
30.01.2021 12:34

Напишите программу которая вычисляет сумму отрицательных элементов массива a[20]. массив заполнить случайными числами из [-1000; 1000]

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Astento
15.07.2020 10:50
Program Project2;
{$APPTYPE CONSOLE}
uses  SysUtils,windows;constnMin=1;nMax=20;typemas=array[nMin..Nmax] of integer;
Vara:mas; i:integer;s:real;begin  setconsoleCP(1251);  setconsoleOutPutCp(1251);  randomize;

for i:=1 to  nMax doa[i]:=random(1000)-500;writeln ('Ìàññèâ:'); for i:=1 to  nMax do beginwrite ('');write  (a[i]:2);writeln ('');end;s:=0;for i:=1 to Nmax dobeginIf a[i]<0 thens:=s+a[i];end;writeln ('Ñóììà îòðèöàòåëüíûõ ýëåìåíòîâ ìàññèâà = ',s:2:2);readln;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота