Роззе
07.11.2022 03:02

Элементы заданной матрицы a(m,n)-целые числа. напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
unisens
02.10.2020 03:54
Var
  a                      : array [1..100,1..100] of longint;
  n,m,i,j,sum,mnj : longint;
begin
  readln(n,m);
  for i:=1 to n do 
    for j:=1 to m do read(a[i,j]);
  sum:=0;
   mnj :=1;
 for i:=1 to n do 
    for j:=1 to m do 
      if (a[i,j] mod 3)=0 or ((a[i,j] mod 2)=0) then begin sum:=sum+a[i,j]); mnj:=mnj*a[i,j]; end;
  writeln(sum,' ',mnj);
 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота