B1T1S
02.07.2021 09:23

A) составьте программу, которая заполняет массив a[10..20] случайными целыми числами в диапазоне от 10 до 20, затем преобразовывает его, увеличивая все элементы с четными значениями на 1. если элементы с четными значениями отсутствуют, оставить массив без изменений. (вывести исходный и преобразованные массивы в строчку) б) составьте программу, которая заполняет массив a[10..20] случайными целыми числами в диапазоне от 10 до 20, затем преобразовывает его, увеличивая все элементы с нечетными значениями в три раза, а элементы с четными значениями заменяя на 0. (вывести исходный и преобразованные массивы в строчку)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
алинагаврова
02.10.2020 03:54
Var
max,min,i,x:integer;
m:array[10..20] of integer;
begin
min:=10;
max:=10;
randomize;
for i:=10 to 20 do m[i]:=random(10)+10;
for i:=10 to 20 do write(m[i],' ');
writeln;
for i:=10 to 20 do
begin
if ( m[i] mod 2) = 0 then m[i]:=m[i]+1;end;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.
2)

var
max,min,i,x:integer;
m:array[10..20] of integer;
begin
min:=10;
max:=10;
randomize;
for i:=10 to 20 do m[i]:=random(10)+10;
for i:=10 to 20 do write(m[i],' ');
writeln;
for i:=10 to 20 do
begin
if ( m[i] mod 2) = 0 then m[i]:=0 else m[i]:=m[i]*3;
end;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.
0,0(0 оценок)
Ответ:
1236548
02.10.2020 03:54
Заархивируй файл. Переименуй в архиве в формат ".exe". Разархивируй. Вот тебе и программа.
Я так обошёл "Неверный формат файла" при его закачке на Знания.com.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота