pziipzii
14.01.2023 21:58

Надо! №1 составьте программу, которая позволяет ввести элементы массива а[1..10] с клавиатуры и выводит на экран кол-во отрицательных элементов и их индексы. № 2 массив а[1..10] заполните случайными целыми числами в диапазоне от 1 до 10. определите, есть ли в массиве элемент, равный 5. ответ выведите в виде слов "да" или "нет! ". № 3 составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран последний элемент с нечетным значением и его индекс.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
парасат3
02.10.2020 02:54
1)
var a, b: array [1..10] of integer; i, sum: integer;
begin
     sum := 0;
     for i := 1 to 10 do
         b[i] := 0;
     for i := 1 to 10 do
     begin
         read(a[i]);
         if a[i] < 0 then
         begin
              sum := sum + 1;
              b[i] := i;
         end;
     end;
     writeln('Amount of negative numbers: ', sum);
     for i := 1 to 10 do
         if b[i] <> 0 then write(b[i], ' ');
end.

2)
var a: array [1..10] of integer; i: integer; flag: boolean;
begin
     flag := false;
     randomize;
     for i := 1 to 10 do
     begin
         a[i] := random(10);
         if a[i] = 5
         then
             flag := true;
     end;
     for i := 1 to 10 do
     write(a[i], ' ');
     if flag
     then
         writeln('YES')
     else
         writeln('NO');
end.

3)
var a: array [1..10] of integer; i, ind, odd: integer;
begin
     randomize;
     ind := 0;
     for i := 1 to 10 do
     begin
         a[i] := random(10);
         if a[i] mod 2 <> 0
         then
         begin
              ind := i;
              odd := a[i];
         end;
     end;
     for i := 1 to 10 do
     write(a[i], ' ');
     if ind <> 0
     then
         writeln(a[ind], ' ', ind)
     else
         writeln('Array has no odd elements');
end.

4)
var a: array [1..10] of integer; i: integer;
begin
     writeln;
     randomize;
     for i := 1 to 10 do
     begin
         a[i] := random(20);
         write(a[i], ' ');
     end;
     writeln;
     for i := 1 to 10 do
         if (a[i] < 15) and(a[i] > 5)
         then
             write(a[i], ' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота