Информатика составить программу, которая формирует массив из 12 случайных целых чисел, принадлежит промежутку [ -20, 20 ], заменяет отрицательные числа на -1 и выводит значения элементов массива до и после замены. : -)
Var a: array [1..12] of integer; i: integer; begin writeln('Начальный вид массива:'); for i := 1 to 12 do begin a[i] := -20 + random(41); writeln('A[', i:2, ']=', a[i]:3); end; writeln('Конечный вид массива:'); for i := 1 to 12 do begin if a[i] < 0 then a[i] := -1; writeln('A[', i:2, ']=', a[i]:3); end; readln end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку