ayupovailinaozhaxj
18.07.2020 10:59

30ку.написать программу на паскале которая определяет и выводит все составные числа n. число n задается во время работы программы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
rutasolntseva
16.06.2019 10:50

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота