diman10000
11.05.2020 08:35

Составить программу на языке паскаль: две точки своими координатами. определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
holoyf
12.07.2020 22:58
Program gt;
var x1,y1,x2,y2,r:real;
begin
readln(x1,y1,x2,y2);
readln(r);
if((sqr(x1)+sqr(y1))<(sqr(x2)+sqr(y2)))then writeln('Pervaya')else
writeln('2-raya');
if(abs(sqrt(sqr(x1)+sqr(y1))-r)<abs(sqrt(sqr(x2)+sqr(y2))-r))
then writeln('Pervaya-ornositelno okru') else writeln('2-raya otnositelno okru');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота