111ВсЕзНаЙкА111
22.05.2022 19:58

1. составьте программу, выясняющую, есть ли в словах х и у одинаковые символы. 2. составьте программу, удваивающую в слове х буквы "б" и "а".

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
апрркн1
13.07.2020 07:04
#include <iostream>
#include <string>
#include <Windows.h>

int main()
{
SetConsoleCP(1251);
SetConsoleOutputCP(1251);

std::string x, y;
std::cin >> x >> y;

//1
bool same= false;
for (auto i : x){
for (auto j : y){
if (i == j) {same = true; break;}
}
if (same) break;
}
std::cout << std::boolalpha << same;

//2
for (unsigned int i = 0; i < x.size(); ++i)
if (x[i] == 'а' || x[i] == 'б') x.insert(x.begin() + i, x[i]);
std::cout << x;

return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота