Уменя есть готовый код паскаля (но я не знаю, по какой причине у меня не получается его увидеть как требуется в (составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. значение n вводится с клавиатуры.) можно переделать код, но без использования uses crt и т.д. сделать нужно с циклом for while и/или repeat. к слову, пользуюсь pascal.abc.net (не знаю, какие значения и где нужно вводить, чтобы получить результат, требуемый в ). program zadacha3; var n, o, p, k, i: integer; a: real; begin repeat write('n = '); readln(n); until (n > 0); i : = 0; k : = 0; p : = 0; o : = 0; repeat write('ввод: '); readln(a); i : = i + 1; if a < 0 then o : = o + 1 else if a > 0 then p : = p + 1 else k : = k + 1; until i = n; writeln('кол-во положительных: ', p); writeln('кол-во отрицательных: ', o); writeln('кол-во нулей: ', k); readln; end.