alizhanayanaoxi717
29.11.2020 22:41

Составить программу: дано двухзначное число, определить входит ли число 4 и 7.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
misterbory
25.05.2020 15:16

То есть вопрос звучит так: состоит ли данное двузначное число из цифр 4 и 7?

Если так, то нужно всего лишь проверить, равно ли введённое число 47 или 74.

 

program test;
var n:integer;
begin
  write('Enter the number: ');
  readln(n);
  if (n = 74) or (n = 47) then
    writeln('numbers 4 and 7 included')
  else
    writeln('numbers 4 and 7 are not included');
readln();
end.

 

Хотя я подозреваю, что вместо и должно быть или.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота