jora2003123
22.01.2021 08:40

Составить программу на языке паскаль : дана матрица а(n, n). составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Лвлчтчтчтчтчь
12.07.2020 13:55
Var n, i, j, ans : integer;
a : array[,] of integer;
begin
    read(n);
    ans := 0;
    SetLength(a, n + 1, n + 1);
    for i := 1 to n do
        for j := 1 to n do
            read(a[i, j]);
    for i := 1 to n do
        for j := i + 1 to n do
            if (a[i, j] > 0) then
                ans := ans + 1;
    writeln(ans);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота