Elizabeth191102
29.11.2020 20:31

Напишите программу в паскале abc, и нарисуйте к ней блок-схему. вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ronaldinho2003
05.10.2020 18:17
Var
i,max,min,res,maxi,mini:integer;
a: array [1..15] of integer;
begin
writeln('Введите числа');
for i:=1 to 15 do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to 15 do
begin
if max<a[i] then begin
max:=a[i];
maxi:=i;
end;
if min>a[i] then begin
min:=a[i];
mini:=i;
end;
end;
if maxi>mini then
res:=maxi-mini
else
res:=mini-maxi;
res:=res-2;
writeln('между максимум и минимум = ', res, ' элементов');
end.
Напишите программу в паскале abc, и нарисуйте к ней блок-схему. вводится массив из 15 элементов,нужн
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота