drunkbear
01.07.2022 14:42

Составьте программу которая формирует массив из 20 целых чисел и вычисляет средние арифметическое нечетный чисел

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anal0l
12.07.2020 11:41
Var mas:array[1..20] of integer;
    i, sum:integer;

begin
     for i:=1 to 20 do
     begin
          mas[i]:=random(99);
         
          write(mas[i], ' ');
     end;
    
     writeln;
    
     i:=1;
     while(i < 20) do
     begin
          sum:=sum+mas[i];
          i:=i+2;
     end;
    
     writeln('Среднее арифметическое нечётных элементов массива ', sum/10);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота