kateshopina0703
04.02.2023 22:52

Составить программу в паскале с использованием циклических операторов: найти все натуральные решения уравнения х^2+у^2=м, где м> 0 задает пользователь

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kaiv
01.10.2020 23:03
var
  x, y, m: integer;
begin
  readln(m);
  writeln('x':6, 'y':6);
  for x := 0 to m do
    for y := 0 to m do
      if (sqr(x) + sqr(y) = m) then
        writeln(x:6, y:6);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота