jungkokBTSlove
28.05.2022 09:48

На паскале написать программу которая в последовательность чисел( натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на 6. программа получает на вход нат числа, признаком окончания ввода явл число 0. могу решить и сам, только нельзя на компе проверить. так что надеюсь на вас.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
adrinaline
07.07.2020 18:20
Var
  a: integer;
  s: longint;

begin
  s := 0;
  a := -32768;
  while a <> 0 do
  begin
    readln(a);
    if a <> 0 then
      if a mod 4 = 0 then
        if a mod 10 = 6 then s := s + a
  end;
  writeln('Сумма равна ', s)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота