SashaKromberg
16.09.2021 02:03

Составить программу начисления стипендии группе студентов из 25 человек по итогам сессии из 5 экзаменов. стипендия в размере 900 рублей начисляется студенту, не имеющему троек. посчитать сумму, необходимую для выплаты стипендии и вывести список студентов, получающий стипендию.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dedsec08
07.07.2020 14:48
Program Stipendiya;
type
Student = record
Ocenka: array [1..5] of Byte;
end;
var
i, j: Byte;
Summa: Integer;
Troechik: Boolean;
Studenti: array [1..25] of Student;
begin
for i:=1 to 25 do
begin
// Zapolnyaem ocenki studentov:
WriteLn('Vvedite ocenki '+IntToStr(i)+' studenta: ');
for j:=1 to 5 do
begin
Write('Ocenka za '+IntToStr(i)+' ekzamen: ');
ReadLn(Studenti[i].Ocenka[j]);
end;
end;

// Chitaem summu

S:=0;

WriteLn('');

for i:=1 to 25 do
begin
//
Troechik:=False;
//
for j:=1 to 5 do
if Studenti[i].Ocenka[j] < 4 then Troechik:=True;
//
if not Troechik then
begin
WriteLn('Vidat stipendiu '+IntToStr(i)+' studentu');
Summa:=Summa + 900;
end;
end;

// Vivod summi vsex stipendii
WriteLn('Summa vsex stipendii = '+IntToStr(Summa));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота