kasoimandarin1
19.10.2020 03:07

Нужно написать программу в паскале описать функцию quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y). с этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LimOonka
07.07.2020 07:39
Var
   i: integer;
   x,y:real;

function Quarter(x,y:real):integer;
begin
if (x>0) and (y>0) then result:=1;
if (x<0) and (y>0) then result:=2;
if (x<0) and (y<0) then result:=3;
if (x>0) and (y<0) then result:=4;
end;

begin
writeln('Введите координаты точки');
readln(x,y);
i:=Quarter(x,y);
writeln('Номер координатной четверти; ',i)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота