Grisha222
19.12.2021 15:18

Написать программу которая классифицирует треугольники равнобедренный, равносторонний,прямоугольный,если даны 3 стороны треугольника.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
grbennikovigor
07.07.2020 01:39
Var a,b,c:real;
begin
writeln('Введите 1 сторону треугольника');
readln(a);
writeln('Введите 2 сторону треугольника');
readln(b);
writeln('Введите 3 сторону треугольника');
readln(c);
if (a=b)and(b=c) then writeln('Равносторонний треугольник')
else if (a=b) or(b=c)or(a=c) then writeln('Равнобедренный треугольник')
else if (sqr(a)=sqr(b)+sqr(c))or(sqr(b)=sqr(a)+sqr(c))or(sqr(c)=sqr(b)+sqr(a)) then writeln('Прямоугольный треугольник')
else writeln('Обычный треугольник');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота