tamilazhakupova
16.05.2021 21:18

Cоставить алгоритм и написать программу. найдите дискриминант квадратного уравнения: y=5x^2+6x-7

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
karikovt
06.07.2020 21:15
#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    float a,b,c;
        int d;
        float x1, x2;

        cout << "ax^2+bx+c=0" << endl;
        cout << "Input a:" << endl;
        cin >> a;
        cout << "Input b:" << endl;
        cin >> b;
        cout << "Input c:" << endl;
        cin >> c;
        d= sqrt(b*b-4*a*c);
        x1=((-1)*b+d)/(2*a);
        x2=((-1)*b-d)/(2*a);
        cout << "x1=" << x1 << endl;
        cout << "x2=" << x2 << endl;
    return 0;
}

Но есть корень из дискриминанта нормально не получится - оно не напишет тебе + √13 допустим, он посчитает корни приблизительно.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота