Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.ученик написал такую программу: var n: longint; begin read(n); while n> 10 do begin n: =n mod 10 end; write(n); end. 1)напишите,что выведет эта программа при вводе числа 1984. 2) пример числа,при вводе которого программа выдаст верный ответ. 3)найдите в программе все ошибки.