Написать программу, которая вычисляет сопротивление электрической цепи, состоящей из двух сопротивлений. сопротивления могут быть соединены последовательно или параллельно.
Program soprotiv; {Название программы} var r1, r2:real; {Задаем переменные} c:byte; begin {Начало программы} write ('Введите 1 сопротивление... '); {Вывод сообщения о вводе данных} readln (r1); {Ввод данных с клавиатуры} write ('Введите 2 сопротивление... '); {Вывод сообщения о вводе данных} readln (r2); {Ввод данных с клавиатуры} write ('Если соединение параллельное, то нажмите клавишу 1, если соединение последовательное - нажмите 0...'); {Вывод сообщения о вводе данных} readln (c); {Ввод данных с клавиатуры} if c=1 {условие} then writeln ('Сопротивление электрической цепи, соединенной параллельно=',(r1*r2)/(r1+r2)) {Вывод значения, при параллельном соединении} else writeln ('Сопротивление электрической цепи, соединенной последовательно=',(r1+r2)); {Вывод значения, при последовательном соединении} end. {Конец программы}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку