mstrager2342
07.10.2021 08:54

Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран: а)количество считанных десятичных цифр; б)количество четных цифр; в)количество нечетных цифр;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Tommh
05.07.2020 16:41
Var
  i,n,x,y,z:integer;
  s:string;
begin
readln(s);
for i:=1 to length(s) do
  if (47<ord(s[i])) and (ord(s[i])<58) then
  begin
  n:=StrToInt(s[i]);
  case n of  0..9:
     begin
     x:=x+1;
     if n mod 2=0 then y:=y+1 else z:=z+1
     end
   end
   end;
writeln('Число цифр: ',x,'; четных цифр: ',y,'; нечетных цифр: ',z)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота