дара23
21.07.2022 16:26

Написать программу которая по вводу с клавиатуры трех действительных чисел выводит на экран сообщение о том могут ли они являться сторонами треугольника

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dick666
03.07.2020 12:16
Нужно воспользоваться свойством треугольников:
Любая сторона треугольника меньше суммы двух других сторон и больше их разности .
Pascal
Var a,b,c:integer;
begin
readln(a,b,c);
if (a<b+c) and (a>b-c) and (b<a+c) and (b>a-c) and (c<b+a) and (c>b-a) then
writeln('Yes')
else
writeln('No');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота