кирилляz
21.02.2023 05:24

Написать программу на паскале. даны три числа m, n, p. определить какое из них равно d. если ни одно не рано d, то найти max(d-m, d-n, d-p)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vols1
03.07.2020 08:42
Var
m, n, p, d: real;

begin
writeln('Введите d');
read(d);
writeln('Введите m,n,p');
read(m, n, p);
if (m = d) or (n = d) or (p = d) then
begin
if (m = d) then writeln('m = d');
if (n = d) then writeln('n = d');
if (p = d) then writeln('p = d');
if (m = d) and (n = d) then writeln('m,n = d');
if (m = d) and (p = d) then writeln('m,p = d');
if (p = d) and (n = d) then writeln('p,n = d');
end else
begin
writeln('Ни одно не равно d');
if ((d - m) > (d - n)) and ((d - m) > (d - p)) then writeln('(d-m) - максимальное');
if ((d - n) > (d - m)) and ((d - n) > (d - p)) then writeln('(d-n) - максимальное');
if ((d - p) > (d - m)) and ((d - p) > (d - n)) then writeln('(d-p) - максимальное');
if ((d - m) = (d - n)) and ((d - m) = (d - p)) and ((d - n) = (d - p)) then writeln('(d-m)=(d-n)=(d-p)');
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота