YourTeaa
12.07.2022 21:58

Нужно написать программу на паскале. вычислить среднеарифметическое четных элементов массива c(10), не меньших 10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Фиджиии
02.07.2020 20:28
Var
c:array[1..10] of integer;
SrAr:real;
k, i, s:integer;
begin
s:=0;{Обнуляем счетчик элементов(к) и сумму(s)}
k:=0;
randomize;
for i:=1 to 10 do {заполняем массив}
 c[i]:=random(50);
for i:=1 to 10 do
 if (c[i] mod 2=0) and (c[i]>10) then {если элемент массива четный и больше 10 увеличиваем счетчик к, увеличиваем сумму s} 
   begin
   k:=k+1; 
   s:=s+с[i];
   end;
SrAr:=s/k;
for i:=1 to 10 do {выводим массив}
write(c[i], ' ');
writeln;
writeln('Sr.Arifmeticheskoe=', SrAr:5:2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота