Макс917572
16.06.2021 17:47

Составить блок схему и решить на языке паскаль: найдите сумму чисел от 5 до 10 с шагом 2. количество чисел и их значение неизвестно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olgagdanova196
16.05.2021 19:40

(см. объяснение)

Объяснение:

program task;

var i: integer;

const N=5;

procedure writeOut(i: integer);

begin

 if(i<N) then write(', ')

 else writeln('.');

end;

begin

 if(N<1) then begin writeln('N>0 и целое!'); exit; end;

 writeln('ЦИКЛ FOR:');

 for i:= 1 to N

   do begin

        write(i); writeOut(i);

      end;

 writeln;

 writeln('ЦИКЛ WHILE:');

 i:= 1;

 while(i<N+1)

   do begin

        write(i); writeOut(i);

        i:= i+1;

      end;

 writeln;

 writeln('ЦИКЛ REPEAT:');

 i:= 1;

 repeat

   write(i); writeOut(i);

   i:= i+1;

 until i=N+1;

end.

0,0(0 оценок)
Ответ:
kdhsjs
03.12.2022 23:09

Автомат получает на вход трехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. Вычисляются два числа - сумма старшего и среднего разрядов, а также сумма среднего и младшего разрядов заданного числа.

Полученные два числа записываются друг за другом в порядке неубывания без разделителей.

Определите, сколько из приведенных ниже чисел могут получаться в результате работы автомата.

1616 169 163 1916 1619 316

В ответе запишите количество чисел и обоснование результата.

ответ

1616 -> 16 и 16, 169 -> 1 и 69, 163 -> 1 и 63, 1916 -> 1 и 916, 1619 -> 16 и 19, 316 -> 3 и 16

9 + 9 = 18 - максимально возможное число.

Оставим все числа, в которых слагаемые меньше или равны 18:

1616 -> 16 и 16, 316 -> 3 и 16

1616 -> 16 и 16 -> 888 (8 + 8 = 16, 8 + 8 = 16) - подходит

316 -> 3 и 16 -> такое число подобрать не получится, потому что между 3 и 16 большая разница и исходного числа не существует.

ответ: 1 число (1616)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота