bayarma58
05.07.2020 12:18

Напишите программу по выдаче рандомной комбинации букв, соответствующую следующим требованиям: - результат должен состоять из 8 символов (букв)- за буквой a могут стоять только буквы d, e, g, i, jза буквой b только e, f, h, j, kза буквой c только f, g, i, k, lза буквой d только a, g, h, j, lза буквой e только a, b, h, i, kза буквой f только b, c, i, j, lза буквой g только a, c, d, j, kза буквой h только b, d, e, k, lза буквой i только a, c, e, f, lза буквой j только a, b, d, f, gза буквой k только b, c, e, g, hза буквой l только c, d, f, h, i обозначения букв по желанию можно заменить на аналоги (a=а, b=б, c=в, d=г, e=д, f=е, g=ж, h=з, i=и, j=к, k=л, l=м) ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
flagvamvruke
08.04.2020 05:50

Better late than never - Лучше поздно чем никогда

Объяснение:

Если четные и нечетные символы зашифрованы разными ключами, то вначале нужно привести их к одному ключу. Известно что разность между k1 и k2 составляет 3 символа. Значит нечетный ключ больше четного на 3. Например если для нечетных символов использовался сдвиг 5, то для четных будет использован сдвиг 2 (потому что 5-3=2).

Что бы привести фразу к одному ключу нужно все четные символы заменить на символы, стоящие на 3 позиции дальше по алфавиту.

W - не трогаем

W- меняем на Z

O - не трогаем

L - меняем на O

Z - не трогаем

I - меняем на L

G - не трогаем

S - меняем на V

O - не трогаем

W - меняем на Z

O - не трогаем

Z - меняем на C

V - не трогаем

F - меняем на I

I - не трогаем

W - меняем на Z

Q - не трогаем

W - меняем на Z

M - не трогаем

Получаем новую фразу:

W Z O O Z L G V O Z O C V I I Z Q Z M

где нечетные и четные символы зашифрованы одним и тем же ключом.

Поскольку в английском алфавите всего 26 букв, то число ключей составляет всего 25 штук, после чего они просто начнут повторятся.

Используя новую полученную фразу и английский алфавит пробуем заменить все буквы на следующие по порядку со сдвигом 1. Получаем текст

XAPPAMHWPAPDWJJARAN - бессмыслица. Тогда пробуем заменить текст со сдвигом на 2 буквы. получим фразу:

YBQQBNIXQBQEXKKBSBO - тоже не имеет смысла.

Сдвиг на 3 и на 4 буквы дает соответственно фразы

ZCRRCOJYRCRFYLLCTCP

ADSSDPKZSDSGZMMDUDQ

что тоже не имеет смысла.

Сдвиг на 5 символов дает фразу

BETTEQLATETHANNEVER - что очень похоже на английские слова (с одной ошибкой).

Делим полученную фразу на слова

BETTEQ LATE THAN NEVER

и приходим к выводу, что зашифровано было английское выражение

Better late than never - Лучше поздно чем никогда.

PS. Единственное, тут есть одна ошибка, вместо слова BETTER после расшифровки получаем слово BETTEQ. Не знаю чем это объяснить. В исходной фразе на этом месте стоит символ I. После приведения к одному коду на этом месте появляется символ L , который стоит на 3 позиции дальше от I. При расшифровке, вместо L получаем символ Q, который стоит на 5 символов дальше L и именно это Q попадает в слово BETTEQ. Скорее всего тут ошибка в условии задачи.

0,0(0 оценок)
Ответ:
Anacmasnz106
10.08.2022 10:31
1)
a) не может, потому что переменные должны всегда начинаться с буквы
b) может
c) не может, слова могут быть разделены только знаком "_",не пробелом!
d) может

2) присваивание, обозначается знаком "="
Например:
sum = 0;

3) 
4 строка - не red, а read
пропущена трока между 2 и 3 строчкой - это begin

4)
var
     S, P, a, b: integer
begin
     write('Введите сторону а: ');
     readln(a);
     write('Введите сторону b: ');
     readln(b);
     
     S = a * b; {нахидим площадь}
     P = (a + b) * 2; {находим периметр}

     writeln('Площадь = ', S, ', периметр = ', P);
end.

5)
Var
     number, {Трехзначное число}
     num1, {Первая крайняя цифра}
     num2, {Вотрая крайняя цифра}
     : integer;
Begin
     write('Введите число');
    readln(number);
   
     num1 = number mod 10;
     num2 = number div 100;
    
     writeln('Сумма крайних цифр числа ', number, ' = ', num1 + num2);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота