Входные данные: a, b (смотри строку с cin>>...;)
Выходные данные: s (смотри строку с cout<<...;)
Из самого задания не совсем понятно, что за входные и выходные данные имеются ввиду. Написал я переменные, которым мы присваиваем значение при вводе и значение переменной, которой мы выводим.