covepoxamu
15.04.2020 11:00

3. составьте программу, которая вычисляет сумму чисел от 1 до n. значение n вводится с клавиатуры. составить блок-схему 40

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
адамчик2
19.11.2021 16:59

1.Составные условия — это условия, состоящие из двух или более простых условий, соединенных с логических операций: and , or , not . Простые условия при этом заключаются в скобки.

2.Простое условие — это два выражения, связанные одним из знаков отношений: = (равно), (больше), = (больше либо равно), ... Составные условия — это условия, состоящие из двух или более простых условий, соединенных с логических операций: and, or, not.

3.Логические операции и таблицы истинности

Логическое умножение или конъюнкция: ...

Логическое сложение или дизъюнкция: ...

Логическое отрицание или инверсия: ...

Логическое следование или импликация: ...

Логическая равнозначность или эквивалентность:

4.Порядок выполнения логических операций в выражении (от наибольшего приоритета к наименьшему): инверсия, конъюнкция, дизъюнкция, импликация, эквивалентность.

5. Условный оператор.

Для проверки условия используются условный оператор.

6. ответ на фоте.


1. Что такое составные условия? 2. Чем отличаются составные условия от простых условий?3. Какие суще
0,0(0 оценок)
Ответ:
PARANO1A
25.01.2021 04:24

p = [1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 21]

q = [3, 6, 9, 12, 15, 18, 21, 24, 27, 30]

ans = 0

for x in range(30):

   if (x in p) and (x in q):

       ans += x

print(ans)

Объяснение:

Это логическое выражение, где переменными выступают выражения (x \in P), (x \in A) и (x \in Q). Обозначим их за p, a и q соответственно. Например, p=1, если x \in P, и 0 иначе. У нас получается следующее выражение:

(p \to a) \lor (\neg a \to \neg q)

Раскроем импликацию и получим:

\neg p \lor a \lor a \lor \neg q

Уберём повторяющуюся a. Наше финальное выражение:

\neg p \lor a \lor \neg q

Таким образом, выражение из условия будет истинно, если число не принадлежит P, или не принадлежит Q, или принадлежит A. Множество A наименьшего размера будет содержать все числа, которые не удовлетворяют условию \neg p \lor \neg q, то есть все числа, которые принадлежат и P, и Q.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота