Дана последовательность целых чисел a1, a2, an. составьте программу, которая выводит разность произведения элементов с нечётным индексом и суммы элементов с чётным индексом.
Program gt; var a:array[1..1000]of integer; n,r,p,s,i:integer; begin read(N); p:=1;s:=0; for i:=1 to n do begin read(a[i]); if(i mod 2=1)then p:=p*a[i] else s:=s+a[i]; end; r:=p-s; writeln(r); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку