Shamаn14
28.04.2023 14:55

( ) 2. Написать программу, которая вычисляет произведение чисел кратных 3 из диапазона от 20 до 40 с шагом 2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ycidenis1
20.08.2022 08:04

#include <iostream>

using namespace std;

int main()
{
setlocale(LC_ALL, "Russian");
char key;
int i;
int a[255];
float arifm=0,sum=0,b=0;

cout << "Введите числа от а до б через пробел! (Условие: a < b)"<<endl;

for (i=0; i < 254; i++){
cin >> a[i];

if(i >= 1 && a[i] < a[i-1]){
break;
}
b++;
}

cout << "Получили числа: ";
for (i=0;i < b; i++){
cout << " " << a[i];
sum += a[i];
}
cout << endl<< "Сумма чисел = " << sum << endl;
arifm = sum / (b);
cout << "Среднее арифметическое = " << arifm << endl;
system ("pause");
}

 

Только не дописал выход из цыкла.. сейчас он при нарушение условия а < б
Если надо думаю справитесь с do while 

0,0(0 оценок)
Ответ:
Милята240106
20.04.2022 05:04

Пакетная передача данных, это передача информации частицами от сетевой единици к другой сетевой единици по протоколу
ТСР\IP :
 TCP - протокол который управляет Пакетной передачей по сети.
(Формирует пакеты, задает размер пакетам так как файлы не идут целиком, а по кусочкам(пакетам))

Принцип так сказать общения по протоколу ТСР:

1.отправляются пакеты по протоколу АДРЕСАЦИИ(Это как почта, вы запаковываете письмо в ТСР и несете в IP) - IP... так ПК узнают куда отправлять пакеты 

2. обрабатывается пакет на удаленном ПК

3. Формируеться как в шаге 1 ответ от удаленной машини с MD5 суммой полученого ею пакета. Отправляется пакет в ответку с удаленного на ваш(как отчет о доставке).

4. Проверяется md5 сумма(как индификационный номер человека, так и у файлов).

5. И лишь тогда отправляет следующий пакет, и все это дело зацикливаеться до полной передачи информации или разрыва соединения Клиент - сервер(Клиент - сервер - клиент).
По-короче: Пакуем пакеты Кидаем, там формируеться отчет, мы его получаем, проверяем то ли получил получатель, если да то отправляем следующий пакет. Вот-так прям как нарко бизнес, порциями)))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота