katmoxie
29.12.2021 10:21

Программу требуется написать на языке pascal: массив нужно заполнить вводом с клавиатурыдан целочисленный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100. составьте программу, которая находит и выводит произведение двузначных элементов массива, которые не делятся на 6. гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NDKinel
30.09.2020 16:54

program raf105;

var a:array[1..30] of integer;

pro,i:integer;

begin

writeln('Вводите 30 чисел по очереди');

pro:=1;

for i:=1 to 30 do

begin

 readln(a[i]);

 if (a[i] <= 99) and (a[i] >= 10) and ((a[i] mod 6) <> 0)

   then pro*= a[i];

end;

writeln('Вывод: ',pro);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота