AWIKOZA
09.04.2022 11:11

Напишите программу на Python для следующей задачи: Дан треугольник сос торонами a,b,c. Если такой треугольник существует, выведите сообщение "треугольник существует" , иначе выведите сообщение «треугольник не существует». Условие существования треугольника является выполнение следующих неравенств: a+b>c, a+c>b, b+c>a

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
2a741
28.04.2021 01:57
program
var
s: string;
a:array[1..4] of integer;
i:integer;
begin
 read(s);
 for i:=1 to 4 do a[i]:=0;
 
 for i:=0 to length(s) do
 begin
    if s[i]=')' then inc(a[1]);
    if s[i]='(' then inc(a[2]);
    if s[i]='!' then inc(a[3]);
    if s[i]='.' then inc(a[4]);
 end;
 
 if(a[1]>a[2])and(a[1]>a[3])and(a[1]>a[4]) then write('Funny')else
 if(a[2]>a[1])and(a[2]>a[3])and(a[2]>a[4]) then write('Sad') else
 if(a[3]>a[2])and(a[3]>a[1])and(a[3]>a[4]) then write('Angry') else
 if(a[4]>a[2])and(a[4]>a[3])and(a[4]>a[1]) then write('Deep') else
    write('Unclear');

end.
0,0(0 оценок)
Ответ:
lydmilagerasim
28.04.2021 01:57

На Python:

number = input('Введите число в двоичной системе счисления: ')

number_of_zeros = 0

number_of_units = 0

for i in number:

   if i == '0':

       number_of_zeros += 1

   elif i == '1':

       number_of_units += 1

try:

#    print('Введеное число: ' + str(int(number, 2)))

   print('Нулей: ' + str(number_of_zeros))

   print('Единиц: ' + str(number_of_units))

except ValueError:

   print('Error')

Объяснение:

закомментировал строку вывода числа в десятичной системе, если понадобится, можно раскомментировать (убрать #), если совсем не надо, можно удалить.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота