hhhhh7777
09.04.2022 23:00

Python В качестве входных данных для Вашей программы выступает одна строка с текстом заранее неизвестной длины, но не короче одного символа и не длиннее 100 символов. Напишите программу, которая бы выводила на экран одно целое число - сумму порядковых номеров в таблице Unicode первого и последнего символов полученной строки.
Если будет введена строка из одного символа, то первый символ следует одновременно считать последним.
На вход программе подаётся одна строка, длина которой не меньше 1 и не больше чем 100 символов.
На выходе программы должно быть единственное натуральное число, являющееся суммой порядковых номеров первого и последнего символов, содержащихся в поданной на вход строке.
Например, в тексте "ABCDE" нужно найти сумму порядковых номеров символа "А" и символа "Е". Это число равно 134 (сумма 65 и 69).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Crdsaadfa
19.03.2020 00:16

1.

const N = 10;

var a: array [1..N] of integer;

i, x: integer;

begin

  write('Введите x: ');

  readln(x);

  for i := 1 to N do

  begin

      a[i] := x + i - 1;

      write(a[i], ' ');

  end;

end.

2.

const N = 10;

var a: array [1..N] of integer;

i: integer;

begin

  a[1] := 1;

  a[2] := 1;

  for i := 3 to N do

  begin

      a[i] := a[i-1] + a[i-2];

  end;

  for i := 1 to N do

  begin

      write(a[i], ' ');

  end;

end.

3.

const N = 6;

var a: array [1..N] of integer;

i, x: integer;

begin

  a[N] := 1;

  for i := N-1 downto 1 do

  begin

      a[i] := 2 * a[i+1];

  end;

   

  for i := 1 to N do

  begin

      write(a[i], ' ');

  end;

end.

Объяснение:

0,0(0 оценок)
Ответ:
sab2021
11.08.2022 08:33

1)

names = []

name = input()

names.append(name)

print('Имя успешно добавлено! Если хотите его удалить, введите - 1')

choice = int(input())

if choice == 1:

    names.remove(name)

2) print(names[0], names[-1])

3) print(len(names)) # names - ваш список.

4)

a = 'При'

b = 'ве'

c = 'т'

print(a + b + c)

5)

set_1 = set(['1', '2', '3'])

set_2 = set(['1', '7'])

print(set_2 - set_1)

6)

text = 'Напишите программу, которая находит самую большую сумму'

print(text.count('и'))

Объяснение:

len - находит длину.

count - Возвращает количество элементов со значением...

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота