LikkaSchool205
23.09.2020 05:01

написать программу на Pascal Сортировка методом выбора
Программа, которая будет выводить вводить массив из рандомных 10 чисел в интервале от -50 до 50 и сортировать их методом выбора. Заранее
Даю максимум!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Imychka
05.07.2021 14:17

      В век стремительно развивающихся технологий, роль компьютеров становится всё больше и больше. Сейчас уже трудно представить любое учреждение будь то офис или школа без компьютера. Компьютер используется преимущественно для создания документов, что является его основной функцией. И действительно создание документов на компьютере обладает рядом преимуществ по сравнению с написанием текстов вручную.

      Во первых, создание документов на компьютере позволяет сэкономить время и усилия. Более того, в компьютерных документах есть возможность делать исправления без необходимости переписывать текст заново. Компактность хранения также является одним из преимуществ компьютерных документов.

     А задумывались ли вы о том, как осуществлялась передача документов до появления компьютеров? Приходилось прибегать к гонцов, писем, посылаемых по почте и т. д. Сейчас же, благодаря комьютеру хранение документов стало простой задачей. Компьютер вмещает в себя массу файлов мог бы даже вместить целую библиотеку.

    Итак, недооценить роль компьютеров нельзя.

0,0(0 оценок)
Ответ:
снежок345
08.12.2020 01:44

Program fantscrin;

 const n = 10;

 Var a: array [1..n] of integer;

     i,j,k:integer; s:real;

Begin

 for i:=1 to n do

   a[i]:=random(20)-10;

 for i:=1 to n do

   write(a[i], '  ');

 for i:=1 to n do

   for j:=1 to n-1 do

     if (a[j]<a[j+1]) then

                      begin

                       k:=a[j];

                       a[j]:=a[j+1];

                       a[j+1]:=k;

                      end;

 writeln('');

 for i:=1 to n do

   write(a[i], '  ');

 s:=0;

 for i:=1 to n do

   if ((a[i] < 0)and(i mod 2=0)) then s:=s+1;

 writeln('');

 writeln(s);

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота