Войти
Регистрация
Спроси ai-bota
SkriN123
25.04.2022 01:16
Написать программу в c++ дан одномерный массив x из n элементов. найти порядковый номер первого по счёту положительного элемента с чётным порядковым номером. все отрицательные элементы после него переписать в массив y.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Эзоз
27.10.2022 10:39
Изучи результат выполнения программного кода и определи соответствующий блок движения спрайта по сцене. 1)2)3)4)5)...
Санси
17.04.2020 09:45
Найти значение логического выражения: . (D 1)v(D 1) D=1...
ola124
18.10.2022 06:55
моделирование при котором исследование объекта осуществляется посредством модели сформированной на языке математики называется это...
Sashska13me
12.06.2022 20:14
Втечении 5 секунд передано сообщение объёмом 375 байт , какова мощность алфавита , если скорость передачи данных 200 символов в секунду ....
АНДрЕЙ12277777
16.02.2022 11:02
Составьте программу, находящую кол-во делителей числа х. число х введите с клавиатуры. (pascal abc (не net))...
soficaflymi
16.02.2022 11:02
Лекция пройдет в аудитории номер 12 несет 6 битов сколько аудиторий в корпусе всего?...
саша4287
16.02.2022 11:02
При какой цене топлива на дорогу из каневской до краснодара будет достаточно 500 рублей, если расстояние равно 125 км, и половина суммы идет на обратную дорогу? расход топлива...
karinabuchneva16
16.02.2022 11:02
Напишите программу в которой определяется сумма s всех целых чисел в интервале заданном переменами n и m а так же сумма sa четных и sb нечетных в этомже интервале...
0202991
16.02.2022 11:02
Как бы вы назвали цвет, заданный на веб-странице в виде кода: #, #ff, #ff, #000066, #ff66ff, #cc, #992299, #999900, #99ff99? найдите десятичные значения составляющих rgb-кода....
Polinkamalina2017
22.06.2021 13:28
Достоверность информации это что примеры...
Ответ:
MrRainClouD
27.06.2020 01:43
#include
#include
#include
#include
int odd(int i)
{
return 2 * i + 1;
}
int square(int i)
{
return i * i;
}
typedef boost::counting_iterator counter;
typedef boost::transform_iterator transformer;
transformer odds(int n)
{
return transformer(counter(n), odd);
}
transformer squares(int n)
{
return transformer(counter(n), square);
}
int main()
{
using namespace std;
cout << "Enter vector length: ";
int n; cin >> n;
cout << inner_product( odds(0), odds(n), squares(0), 0 ) << endl;
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота