qweuio
17.11.2020 08:17

Написать программу на языке Python и прикрепить текст программы, а также результат работы программы в виде скриншота. Условие: Задать массив из 15 элементов. Заполнить его случайными величинами в интервале [15, 30]. Определить, имеются ли в одномерном массиве одинаковые элементы. Вывести их на экран.
Если таковых элементов не найдено, то вывести сообщение об ошибке.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladyulin
29.04.2021 23:44
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
0,0(0 оценок)
Ответ:
tarasIT
15.10.2022 21:16
Rem BASIC-256
cls
errors = 0
print "Введите текст > ";

rem Пользователь вводит текст
input a$

rem Перебираем все буквы с начала и до предпоследней
for i=1 to length(a$)-1

rem Если встречаем букву Ч или Щ
if mid(a$, i, 1) = "ч" or mid(a$, i, 1) = "щ" then

rem Тогда проверяем следующую за ней букву.
rem Если это буква я, тогда подсчитываем очередную ошибку
if mid(a$, i + 1, 1) = "я" then errors = errors + 1
end if

rem Переходим к следующей букве
next i

rem Вывод результата
print "Количество ошибок в тексте ";
print errors

rem Конец программы
end
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота