Nshok1
08.01.2021 04:28

Составьте программу возведения в степень любого числа, не используя операцию возведения в степень. Составьте программу, которая будет печатать на экране таблицу умножения на любое число.
Напечатать таблицу перевода между весом в фунтах и весом в килограммах для значений от 1 до 10 фунтов, если известно, что один фунт 453,6 г?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
marsik12912
20.07.2022 15:16
Var
 a: array[0..99] of integer;
begin
  //заполняем массив случайными числами
  Randomize();
  for var i:=0 to 99 do a[i]:=random(-100,100);
 
  //а теперь заменяем все отрицательные элементы на ноль
  for var i:=0 to 99 do 
    if (a[i]<0) then a[i]:=0;
end.

Вот второй вариант программы, со вводом с клавиатуры и со сдвигом нулевых элементов в хвост массива
program pr_1;constn = 6;varA: array [1..n] of integer; n1: integer;
beginWrite('введите ');for i := 1 to n doread(A[i]);  n1:=n;  for var i:=n downto 1 do{в цикле просматриваем элементы массива}  begin    if A[i] < 0 then {проверяем, нужно ли удалять i-ый элемент}    begin{если нужно – удаляем i-ый элемент}      for var j := i to n1 - 1 do         A[j] := A[j + 1]; {сдвигаем}       A[n1]:=0;        Dec(n1); {уменьшаем количество элементов}    end;  end;  for var i:=1 to n1 do    write(A[i], ' ');end.
0,0(0 оценок)
Ответ:
anyutra
04.02.2022 02:50
1) в русском алфавите 33 буквы
       33-4=29 заглавных букв используются в идентификаторе 
            и 9 цифр    29+9=38 символов используется в идентификаторе
2)   2^5<38<2^6  --->  6 бит для кодировки одного символа
3)  6 бит * 6 символов=36 бит =[36:8] =5 -байт - целое кол-во байт для                                                                                      одного идентификатора
4)   5*180=900 байт≈1 Кбайт   < ответ
         или   900:1024=0,87891 Кбайта  < или такой ответ???
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота