dashadasha22399
14.08.2022 16:43

Составить программу нахождения суммы всех делителей

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
rmaro82
27.01.2022 22:00

Відповідь:

#include <iostream>

using namespace std;

int sumdiv(int n){

int sum = 0;

for(int i = 1; i <= n; i++){

 if(n % i == 0){

  sum += i;

  cout << i << endl;

 }

}

return sum;

}

int main(){

int n;

cout << "Enter n: ";

cin >> n;

cout << "Sum = " << sumdiv(n) << endl;

return 0;

}

Пояснення:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота